Kinde - Service degradation for US region – Incident details

Service degradation for US region

Resolved
Degraded performance
Started about 1 year agoLasted 20 minutes

Affected

US region

Updates
  • Resolved
    Resolved

    The service degradation has been resolved. The root cause was identified and a fix was applied to improve the handling of high latency events.

    Note that additional performance enhancements are being applied in upcoming releases to mitigate against service degradations like this.

  • Investigating
    Investigating

    We experienced a spike in latency in our US region for a limited group of customers. Users authenticating may experience delays or time outs.