Kinde - Email delivery problems for US region – Incident details

Email delivery problems for US region

Resolved
Partial outage
Started 9 months agoLasted about 3 hours

Affected

US region

Partial outage from 12:24 AM to 3:51 AM

Email delivery

Partial outage from 12:24 AM to 3:51 AM

Updates
  • Resolved
    Resolved

    All the backlogged emails have been cleared and email sending is back to normal. We have put measures in place to address the issue.

  • Identified
    Update

    Just a quick update, emails are starting to flow again for the US region. There's still a backlog to process and we'll keep updating until everything's cleared out.

  • Identified
    Identified

    Just a quick update that the team are actively working on a temporary fix to unblock email flow.

  • Investigating
    Investigating

    Users accessing customer systems in the US region are not receiving emails reliably for events such as email OTP or password resets. We are currently investigating and will provide updates regularly.