Kinde - Email delivery issues for US region – Incident details

Email delivery issues for US region

Resolved
Degraded performance
Started 9 months agoLasted about 4 hours

Affected

US region

Degraded performance from 8:20 PM to 12:07 AM

Email delivery

Degraded performance from 8:20 PM to 12:07 AM

Updates
  • Resolved
    Update

    Emails failed to be sent to users in the US regions, impacting passwordless sign in via email, sign up verifications, password resets, and other email-based communications. Other forms of authentication such as social integrations, enterprise connections, and password sign in were not affected. The email delivery problems were caused by cross-region network failures and lasted 29 minutes. The team will remove cross region points of failure to minimize dependencies when sending emails.

  • Resolved
    Resolved

    The backlog of emails has been cleared, and email sending operations have returned to their usual functionality. We have implemented measures to rectify the issue and prevent its recurrence.

  • Investigating
    Investigating

    Users accessing customer systems in the US region are not receiving emails reliably for events such as email OTP or password resets. We are currently investigating and will provide updates regularly.