Kinde - Service degradation for US region – Incident details

Service degradation for US region

Resolved
Degraded performance
Started 6 months agoLasted about 3 hours

Affected

US region

Degraded performance from 5:59 PM to 8:42 PM

Authentication

Degraded performance from 5:59 PM to 8:42 PM

Custom domains

Degraded performance from 5:59 PM to 8:42 PM

Email delivery

Degraded performance from 5:59 PM to 8:42 PM

New user registration

Degraded performance from 5:59 PM to 8:42 PM

SMS delivery

Degraded performance from 5:59 PM to 8:42 PM

Updates
  • Resolved
    Update

    The US region experienced degradation and slower than normal loading of pages and responses from the API. A service designed to help manage connections into the backend infrastructure experienced problems, which then caused 5xx errors on our frontend services. The services handling connections was reset to resolve the issue resulting in all all services returning to normal.

  • Resolved
    Resolved

    The service degradation has been resolved and the root cause identified. All systems in the US region are now performing as expected.

  • Investigating
    Investigating

    A service degradation was detected for our US region where responses from our API are very slowly or timing out.