Kinde - Service degradation for US region – Incident details

Service degradation for US region

Resolved
Degraded performance
Started 6 months agoLasted 10 minutes

Affected

US region

Degraded performance from 10:51 PM to 11:01 PM

Authentication

Degraded performance from 10:51 PM to 11:01 PM

Custom domains

Degraded performance from 10:51 PM to 11:01 PM

Email delivery

Degraded performance from 10:51 PM to 11:01 PM

New user registration

Degraded performance from 10:51 PM to 11:01 PM

SMS delivery

Degraded performance from 10:51 PM to 11:01 PM

Updates
  • Resolved
    Update

    A service degradation was detected for our US region, where responses for authentication and APIs were very slow. A caching mechanism used to accelerate the retrieval of refresh tokens failed and caused excessive 5xx errors for client connections. This was remediated during the incident with additional recovery methods put in place to prevent this behaviour.

  • Resolved
    Resolved

    The service degradation has been resolved and the root cause identified. All systems in the US region are now performing as expected.

  • Investigating
    Investigating

    A service degradation was detected for our US region, where responses are very slow.