Kinde - Email and SMS delivery – Incident details

Email and SMS delivery

Resolved
Partial outage
Started 16 days agoLasted about 3 hours

Affected

US region

Partial outage from 5:05 PM to 8:01 PM, Operational from 8:01 PM to 8:13 PM

Email delivery

Partial outage from 5:05 PM to 8:01 PM, Operational from 8:01 PM to 8:13 PM

SMS delivery

Partial outage from 5:05 PM to 8:01 PM, Operational from 8:01 PM to 8:13 PM

Updates
  • Update
    Update

    An alert was raised with the Kinde support team regarding delayed emails for US region customers. It was identified that a task consumed all available workers concurrently and prevented emails from being delivered in a timely manner due to the backlog. To fix the immediate issue, the faulty task was killed and all undelivered time sensitive emails were expired. The team will implement stricter quality of service queues for email delivery and segregate the high resource usage tasks to prevent delays due to unrelated tasks.

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Update
    Update

    We are still looking into the email sending issue. We will update no later than 20:30UTC

  • Investigating
    Investigating
    We are currently investigating this incident.